aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Ashworth <bosrsf04@gmail.com>2019-03-04 10:25:34 -0500
committerDrew DeVault <sir@cmpwn.com>2019-03-04 12:50:56 -0500
commite8eab3b82584290e8e22808c3af30e45f701c6e5 (patch)
treefaf52468587b927c78da5798ba4804bc1e1769d0
parent0c1605784de3385ecd143fd26d17fac8cfea9b43 (diff)
downloadsway-e8eab3b82584290e8e22808c3af30e45f701c6e5.zip
sway-e8eab3b82584290e8e22808c3af30e45f701c6e5.tar.gz
sway-e8eab3b82584290e8e22808c3af30e45f701c6e5.tar.bz2
meson: update scdoc requirement to >= 1.9.21.0-rc5
Since scdoc 1.9.1 is bugged, this updates the meson version check to >= 1.9.2 and drops the version requirement from the README. This should make it more obvious to users who have 1.9.1 that they need to update scdoc to be able to compile man pages and hopefully cut down on the duplicate issues
-rw-r--r--README.md2
-rw-r--r--meson.build2
2 files changed, 2 insertions, 2 deletions
diff --git a/README.md b/README.md
index 832a309..cb3f466 100644
--- a/README.md
+++ b/README.md
@@ -40,7 +40,7 @@ Install dependencies:
* pango
* cairo
* gdk-pixbuf2 \*\*
-* [scdoc](https://git.sr.ht/~sircmpwn/scdoc) >= 1.9.0 (optional: man pages) \*
+* [scdoc](https://git.sr.ht/~sircmpwn/scdoc) (optional: man pages) \*
* git \*
_\*Compile-time dep_
diff --git a/meson.build b/meson.build
index 270dc6b..a08b260 100644
--- a/meson.build
+++ b/meson.build
@@ -95,7 +95,7 @@ conf_data.set10('HAVE_SYSTEMD', systemd.found())
conf_data.set10('HAVE_ELOGIND', elogind.found())
conf_data.set10('HAVE_TRAY', have_tray)
-scdoc = dependency('scdoc', version: '>=1.9', native: true, required: get_option('man-pages'))
+scdoc = dependency('scdoc', version: '>=1.9.2', native: true, required: get_option('man-pages'))
if scdoc.found()
scdoc_prog = find_program('scdoc')
sh = find_program('sh')